convert goldengate to integrated mode

init.ora
*.compatible='11.2.0.3'
*.streams_pool_size=4096m

ext01.prm
--@@TRANLOGOPTIONS ASMUSER SYS@+ASM1, ASMPASSWORD welcome1
--@@TRANLOGOPTIONS DBLOGREADER, DBLOGREADERBUFSIZE 4194304, BUFSIZE 8388608
TRANLOGOPTIONS INTEGRATEDPARAMS (max_sga_size 2048, _LOGMINER_READ_BUFFERS 128, parallelism 16)

create.obey
--ADD EXTRACT ext01, TRANLOG, THREAD 1,  BEGIN NOW
ADD EXTRACT ext01, INTEGRATED TRANLOG, BEGIN NOW

but there is errors when start extract

2013-04-23 02:35:01  ERROR   OGG-02021  Oracle GoldenGate Capture for Oracle, ext01.prm:  This database lacks the required libraries to support integrated capture.
2013-04-23 02:35:01  ERROR   OGG-01668  Oracle GoldenGate Capture for Oracle, ext01.prm:  PROCESS ABENDING.

search google and mos, found following :
11.2.0.3 Database specific bundle patch for Integrated Extract 11.2.x [ID 1411356.1]
http://gavinsoorma.com/2013/01/goldengate-integrated-capture-mode/

Click to add to Favorites		11.2.0.3 Database specific bundle patch for Integrated Extract 11.2.x [ID 1411356.1]	To BottomTo Bottom	
Modified:11-Mar-2013Type:BULLETINStatus:PUBLISHED[ EXTERNAL ]Priority:1	
Show document comments (11)Add commentView document statisticsView authoring history	Rate this document	Email link to this document	Open document in new window	Printable Page

In this Document
	Purpose
	Scope
	Details
	References

Applies to:
Oracle GoldenGate - Version 11.2.0.0.0 and later
Information in this document applies to any platform.
Purpose

To ensure that customer who are using OGG 11.2.x Integrated Extract have the correct database release and the correct database patch bundle to support the product due to required DB functionality.

NOTE : No patch is required if you are only using the Classic Extract
Scope

This is for all intended users of Oracle Goldengate Integrated Extract
Details

When running the Oracle Goldengate INTEGRATED Extract 11.2.x there are the following requirements

- Oracle RDBMS must be 11.2.0.3 or later
and
- You must apply the RDBMS patches as follows :

For Exadata Customers,  the latest recommended patch for IE is included in bundled patch bp14 11.2.0.3.14 14744263 

For non-Exadata platforms OGG/RDBMS bp14, use the following MLR bug number for specific RDBMS platform and psu:
11.2.0.3.0    15987144   MLR bug for 14744263 and 14551959 (13328193,13516727,13652437,14050233,14175146,14744263)

For Exadata Customers,  the latest recommended patch for IE is included in bundled patch bp14 11.2.0.3.14 14744263
download patch 14744263
not found this path in mos……
just search for exadata bp14,found follwoing
QUARTERLY DATABASE PATCH FOR EXADATA (JAN 2013 – 11.2.0.3.14) – Patch 15835102
downloading~~~~~~~~~~~~~~
BUT:This patch has been superseded. Please see the reason stated below.Reason for SupersedingQuarterly Database patch 15835102 for Exadata (JAN 2013 – 11.2.0.3.14) is superseded by Quarterly Database patch 16474946 for Exadata (APR 2013 – 11.2.0.3.17)
so try bp 17 first.

 

 

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注